Increased latency for Universal 3.5 Pro Realtime model

Incident Report for AssemblyAI

Resolved

This incident has been resolved. From 14:15-14:45 UTC customers experienced increased latency when using our Universal 3.5 Pro Realtime model on the US endpoint. The EU endpoint was not affected. Sessions continued to function during this time without any errors.
Posted Aug 25, 2026 - 15:01 UTC

Monitoring

The fix has been implemented and latency has recovered as of 14:45 UTC. The team is continuing to monitor the situation.
Posted Aug 25, 2026 - 14:57 UTC

Identified

The issue has been identified and our team is working on a fix.
Posted Aug 25, 2026 - 14:57 UTC

Investigating

We are currently investigating an issue where there is increased latency for our Universal 3.5 Pro Realtime model on the US endpoint. This began at 14:15 UTC.
Posted Aug 25, 2026 - 14:55 UTC
This incident affected: APIs (Streaming API).